Original War Support Bug Tracker
Please log in to bookmark issues
CLOSED  Bug report #26  -  range check error
Posted Mar 09, 2014 - updated Feb 27, 2015
icon_info.png This issue has been closed with status "Closed" and resolution "DUPLICATE".
Issue details
  • Type of issue
    Bug report
  • Status
  • Assigned to
  • Progress
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Time spent
    No time spent
  • Category
    Not determined
  • Resolution
  • Priority
    Not determined
  • Reproducability
    Can't reproduce
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
Issue description
I'm unable to launch 7th mission of Arabian CampaignI'm unable to play any mission (both original and mod) because of unknown Range Check error. Also, I can't launch any mission, using the OW_editor. When my mod is loaded in it "Range Check Error" window appears (even before loading any of the mission). When I'm going to load one - the scripts are compiling smoothly but the map stays "white".

Error log after loading Ar07 (mission loads nicely but in the moment, map is going to be displayed - error. Edit: I'm using win8. Don't remember installing any updates and applications. I was able to play without any problems until 4.03. I've finished Ar06, clicked next mission and got this error, so I was thinking it's ArCamp fault. From now on I can't launch any mission and use my ow_editor.

It's not 1.12.10 fault. I've tried to play on my Steam version (1.12.8) - same error. I used it once (to check the English version of the game and it was running smoothly), but now it's broken as well. I'm aware of the fact it's mine or my system's fault. Just looking for some tips. I don't thin reinstalling the game would make any difference.
  1. General Info
  2. ------------
  3. Application : Owarfull
  4. Version :
  6. ModName : MyMod
  7. ModDir : MyMod
  8. ModVer : 1.0 (1.48)
  10. ErrorType : Unknown
  11. ErrorText : Range check error
  13. Exception : None
  15. Params :
  16. ParamCount : 0
  18. Game Info
  19. ---------
  20. Multiplayer : False
  21. Multi.GameState : Undef
  22. Multi.ChatConnLost : False
  23. Multi.IAMServer : False
  24. Multi.Joined : False
  25. Multi.Loaded : False
  26. Multi.MapVersion : 0
  27. Multi.OffLine : False
  28. Multi.OnLine : False
  29. Multi.ServerLost : False
  30. Multi.StatusText :
  31. MultiDef.MapName :
  33. mission_number : 7
  34. mission_campaign : 2
  35. camp_names[mission_campaign] : Ar
  36. mission_names[mission_number] : 07
  37. game_difficulty : 2
  38. ingame_video : True
  39. stop_talking : False
  40. stop_action : False
  41. end_of_mission : 0
  42. end_the_mission_allowed : False
  43. dialogue_skipped : False
  44. last_title_ident : -1
  45. last_title_unit : 0
  46. last_title_radio : False
  47. last_title :
  49. Random Stuff
  50. ------------
  51. GodMode : False
  52. DeveloperMode : False
  53. ModCBMode : False
  54. OfficialMod : False
  55. InterfSide : 3
  57. Windows Info
  58. ------------
  59. Product : Windows XP
  60. Win32MajorVersion : 5
  61. Win32MinorVersion : 1
  62. BuildNumber : 2600
  63. ServicePack : Service Pack 3
  64. ServicePackMajor : 3
  65. ServicePackMinor : 0
  67. Physical Memory : 1024MB
  68. CPU Name : Intel(R) Core(TM)2 Duo CPU T6600 @ 2.20GHz
  69. CPU Clock : 2195Mhz
  70. Current CPU Clock : 2195Mhz

Edit2: Reinstallation gave its results. Anyway, isn't it strange, that my both versions were broken the same time by the same error?

PS. Please, enable commend editing.

Steps to reproduce this issue
Can't load any of the mission in ow_editor, can't load the mission 07.

Comment posted by
Mar 09, 12:55
Oh. My mistake. RangeCheck Error after starting any of the mission. Tried on my standard and Steam
Comment posted by
Mar 09, 14:22
Deleted libraries downloaded from the steam guides. Same effect. They're not the cause of the problem.
Comment posted by
Mar 09, 14:32
Next mistake; Range check error in every mission, every mod, every version of the game.
Comment posted by
Mar 09, 17:29
Does the following fix the problem? The NORANGECHECK flag was accidentally removed in one of the builds (I think it was added in a 1.12.8 build and most likely removed by accident in a 1.12.8 build).

- Owar_1.12.10.2_2014_02_27.rar
Comment posted by
Mar 09, 17:56
I can't say. It's really strange. I've reinstalled my 1st copy but left Steam version intact. After reinstallation the game worked on 1.02 and then after I installed the 1.12.10 patch - without any problem. I was certain the Steam version (1.12.8) would be still bugged, but it appears to be working fine now (I was going to apply the newest patch and try the fix). It's quite enigmatic for me.
Comment posted by
Mar 09, 21:09
Marking as Can't Reproduce but will leave open.
Comment posted by
May 01, 10:31
OK. Range check error came back. The files, provided by you won't fix the problem (checked on my basic (newest patch) and Steam (steam patch ver.) version of the game).

Again, both versions are broken and I can't open any mission in editor. In game - its loading without any problem, but after that error appears (I still can hear the dialogues and vehicle sounds).

IDK what's causing the problem - played OW about two weeks ago and everything were working fine. Maybe it's editor-connected problem. Today I launched the mod which is containing the data from /Disc2 (to open the original missions).
Comment posted by
icon_reply.pngMay 01, 14:32, in reply to comment #11
Have you tried disabling every background application (Anti-Virus/etc) which is not necessary for windows to run? It makes no sense that it doesn't work for any version, then works, then doesn't work for any version (Especially versions located in different places).

Could you try the following:

- OwarFull_1.12.10.10_2014-05-01.rar
Comment posted by
May 01, 19:19
I'm running mIRC, Evolve and Steam in my background only. Any other programs refer to hardware drivers.

After pasting the .exes - OWsteam.dll not found.
Comment posted by
icon_reply.pngMay 02, 00:02, in reply to comment #13
Doh. I have re-uploaded it.

Its very rare but 3rd party applications (Doesn't matter what they are or what they do) can sometimes screw up other applications. It sounds like its either driver related or a 3rd party application, simply because it magically doesn't work, works and then doesn't work. Given all versions seem to be effected its not going to be any changes from one version to the next.

I am convinced that Original War is doing things it shouldn't do, like going out of bounds, etc(Turn on the Compiler Optimisation Flag and OW crashes) but with 99% of computers it seems to run fine (Excluding Win 8 :P ).

P.S The only thing you would notice with steam integration is that the multiplayer name if ran through steam is changed to your current steam name. Technically the first achievement would work, but you don't have the modified map files to trigger it.
Comment posted by
May 02, 10:56
Thanks, The issue is fixed now, thanks to you and your files.
Comment posted by
May 02, 15:45
Anyway, it looks like mouse cursor display is missing now. http://i57.tinypic.com/2qs1k6v.png

It won't show after mousing over the vehicles, buildings, nor selecting the options from the ui.
Comment posted by
May 02, 16:53
It seems, that a lack of the cursors is my fault. Reinstalled the game and it was missing even on 1.02. I dunno what's happening; I'll try to leave only Steam version installed.
Comment posted by
icon_reply.pngMay 02, 18:06, in reply to comment #17
If your not getting range checks in 1.02 any-more then its nothing that i changed. One versions files can't effect another.

Have you recently installed new graphics card drivers? Do you have Direct X 9 installed (Note: Having a more recent version doesn't mean you have DX9. Im guessing the DX9 setup for vista/7 should work on Windows 8)? DirectX 5/6 would be preferable but i doubt it would work on anything above XP (Direct X 5/6 still had DirectDraw implemented in its self. Rather than a compatibility layer in latter versions).
Comment posted by
May 02, 19:25
I've got DirectX11 installed. I can't install the 9th version (only up to XP or Windows Server 2003). I'm trying to keep it up to date.

I've updated my Windows, restarted the computer and the cursor's working smooth now. It was quite strange but I'm almost sure it was a fault of my software.
Comment posted by
icon_reply.pngMay 02, 22:42, in reply to comment #19
The DX9 Web Installer is meant to work on Windows 8. You can have multiple versions of Direct X installed(It doesn't overwrite), and probably already do if you have installed a few Direct X games(As they like to install specific versions of DX. OW from a CD if i remember correctly will try to install DX5 or 6).

Since its something that comes and goes, and which also effects all OW versions, its some software/driver thats doing it.
Comment posted by
May 15, 07:56
I was getting a black screen on on starting a mission but i tried the rar file in 8 and it fixed my black screen issue. Would it help to report the memory access violation errors I see in wine?
Comment posted by
icon_reply.pngMay 15, 08:08, in reply to comment #22
I can confirm post 17 about the cursor not changing for wine.
Comment posted by
icon_reply.pngMay 15, 08:35, in reply to comment #23
jmwatt wrote:
I can confirm post 17 about the cursor not changing for wine.

Antitheus was using Windows 8.

jmwatt wrote:
I was getting a black screen on on starting a mission but i tried the rar file in 8 and it fixed my black screen issue. Would it help to report the memory access violation errors I see in wine?

It can't hurt, but i don't know if it would help. I am not sure if the memory locations will be the same. Also some bugs will likely be the result of WINE (Since its not a perfect emulation of Windows).
Comment posted by
Feb 27, 10:55
Should be fixed if its the same as the other range check error

The issue was updated with the following change(s):
  • This issue has been closed
  • This issue's progression has been updated to 100 percent completed.
  • The resolution has been updated, from CAN'T REPRODUCE to DUPLICATE.
  • Information about the user working on this issue has been changed, from Stucuk to Not being worked on.